Solucionar el error de Java en Chrome: No se admite este complemento

Atención: A partir de septiembre de 2015, Google Chrome deja de dar soporte a plugins NPAPI, con lo que la opción citada a continuación ya no estará disponible más, a no ser que tengas una versión del navegador anterior.

A partir de la versión 42 de Google Chrome, nos podemos encontrar en las webs que usen complementos de Java con que éste no estará disponible, indicándonos el navegador que no puede ejecutar dicho complemento Java.

Para solucionarlo, abrimos Google Chrome y, en la dirección escribimos lo siguiente:

chrome://flags/

Buscamos y habilitamos el apartado que se llama:

Habilitar NPAPI Mac, Windows

Quedando como en la siguiente imagen:

Pulsa en la imagen para agrandarla

A continuación sólo tenemos que reiniciar el navegador, cerramos todas las pestañas/ventanas y volvemos a abrir Google Chrome.

Con ésto no tendremos problemas, eso si, si no tenéis Java actualizado, éste es el momento de hacerlo. Una vez que tenemos activado lo anterior, accedemos a la siguiente dirección:

https://www.java.com/verify

Pulsamos el botón rojo que se llama Acepto. Continuar y nos informará si tenemos la última versión disponible o tendremos que actualizar y, ni que decir tiene, que si no la tenéis, actualizad !!

11 comentarios en “Solucionar el error de Java en Chrome: No se admite este complemento

  1. Diegao

    Buenas…tengo instalada en Windows 7, el navegador Chrome Versión 45.0.2454.85 dev-m y cuando ingreso en chrome://flags/, no encuentro ninguna referencia a Habilitar NPAPI Mac, Windows.

    Sigo con el problema que en paginas con Java, aparece el mensaje “No se admite este complemento”

    Alguna otra posible solucion ?

    Muchas gracias.

    Responder
    1. Sploft.com Autor

      Hola,

      Desgraciadamente Google a desactivado la compatibilidad para todos los complementos Java en Google Chrome desde esta última versión 45 …

      Actualmente estamos intentando ver como poder activarlo de nuevo. En cuanto podamos lo compartimos con todos.

      Un saludo.

      Responder
  2. CrisdR

    Además, al intentar actualizare Java, me encuentro con este mensaje:
    Chrome no longer supports NPAPI (technology required for Java applets)
    ¿Hay alguna solución?
    Gracias!

    Responder
    1. Sploft.com Autor

      Hola CrisdR,

      Creo que se te ha pasado leer el primer párrafo :S. Siento decirte que desde septiembre de este año 2015, Google ha dejado de dar soporte a dicha tecnología en Chrome. Sólo te queda cambiar de navegador si o si.

      Un saludo.

      Responder
    1. Sploft.com Autor

      Hola Antonio,

      Al igual que al compañero anterior, se te ha pasado leer el primer párrafo. Google ha dejado de dar soporte para ello, con lo que es imposible hacer uso de Java en Google Chrome. Sólo te queda utilizar otro navegador, pero si lo haces, no hace falta que hagas nada más, tan sólo instalar Java.

      Un saludo.

      Responder
    1. Sploft.com Autor

      Hola Enzo,

      Por desgracia, como se indica al principio de la entrada, Google ha dejado de dar soporte a dicha opción, y por consiguiente a todo lo que use Java en su navegador. Lo único que puedes hacer es cambiar de navegador.

      Un saludo.

      Responder
  3. int-eligente

    Osea que no tiene solución, ¿Sabes algún programa para que sea un asistente de consultas conectado a una base de datos para generar las queries de forma visual? El que usaba era el de Java con applets que con la versión 45 de Chrome ya no me vale.

    Un saludo.

    Responder

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *